summaryrefslogtreecommitdiff
path: root/qt/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'qt/configure.in')
-rw-r--r--qt/configure.in75
1 files changed, 75 insertions, 0 deletions
diff --git a/qt/configure.in b/qt/configure.in
new file mode 100644
index 000000000..1a235dbf3
--- /dev/null
+++ b/qt/configure.in
@@ -0,0 +1,75 @@
+AC_INIT(qt.c)
+AM_INIT_GUILE_MODULE(qt)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_RANLIB
+
+CY_AC_WITH_THREADS
+
+threads_enabled=false
+if test "$cy_cv_threads_package" = COOP; then
+ threads_enabled=true
+fi
+
+# Determine the host we are working on
+AC_CANONICAL_HOST
+
+case "$host" in
+i386-*-*|i486-*-*|i586-*-*)
+ qtmds_s=$srcdir/md/i386.s
+ qtmd_h=$srcdir/md/i386.h
+ qtmdc_c=$srcdir/md/null.c
+ ;;
+mips-sgi-irix5*)
+ qtmds_s=$srcdir/md/mips-irix5.s
+ qtmd_h=$srcdir/md/mips.h
+ qtmdc_c=$srcdir/md/null.c
+ qtdmdb_s=$srcdir/md/mips_b.s
+ ;;
+mips-*-*)
+ qtmds_s=$srcdir/md/mips.s
+ qtmd_h=$srcdir/md/mips.h
+ qtmdc_c=$srcdir/md/null.c
+ qtdmdb_s=$srcdir/md/mips_b.s
+ ;;
+sparc-sun-solaris2.*)
+ qtmd_h=$srcdir/md/sparc.h
+ qtmdc_c=$srcdir/md/null.c
+ qtmds_s=$srcdir/md/sparc.s
+ qtdmdb_s=$srcdir/md/sparc_b.s
+ ;;
+sparc-*-*)
+ qtmd_h=$srcdir/md/sparc.h
+ qtmdc_c=$srcdir/md/null.c
+ qtmds_s=$srcdir/md/_sparc.s
+ qtdmdb_s=$srcdir/md/_sparc_b.s
+ ;;
+*)
+ echo "Unknown configuration; threads package disabled"
+ threads_enabled=false
+ ;;
+esac
+
+
+if $threads_enabled; then
+ target_libs=libqt.a
+else
+ target_libs=
+fi
+
+# Give the Makefile the names of the object files that will be
+# generated by compiling $qtmdc_c and $qtmds_s.
+qtmdc_o="`echo ${qtmdc_c} | sed -e 's:^.*/::' | sed -e 's:\.c$:\.o:'`"
+qtmds_o="`echo ${qtmds_s} | sed -e 's:^.*/::' | sed -e 's:\.s$:\.o:'`"
+
+AC_SUBST(target_libs)
+AC_SUBST(qtmd_h)
+AC_SUBST(qtmdc_c)
+AC_SUBST(qtmdc_o)
+AC_SUBST(qtmds_s)
+AC_SUBST(qtmds_o)
+AC_SUBST(qtmdb_s)
+
+AC_OUTPUT(Makefile qt.h md/Makefile time/Makefile)