summaryrefslogtreecommitdiff
path: root/doc/ref/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/ref/Makefile.am')
-rw-r--r--doc/ref/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/doc/ref/Makefile.am b/doc/ref/Makefile.am
new file mode 100644
index 000000000..9f264c31c
--- /dev/null
+++ b/doc/ref/Makefile.am
@@ -0,0 +1,49 @@
+## Process this file with Automake to create Makefile.in
+##
+## Copyright (C) 1998 Free Software Foundation, Inc.
+##
+## This file is part of GUILE.
+##
+## GUILE is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as
+## published by the Free Software Foundation; either version 2, or
+## (at your option) any later version.
+##
+## GUILE is distributed in the hope that it will be useful, but
+## WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public
+## License along with GUILE; see the file COPYING. If not, write
+## to the Free Software Foundation, Inc., 59 Temple Place, Suite
+## 330, Boston, MA 02111-1307 USA
+
+AUTOMAKE_OPTIONS = gnu
+
+info_TEXINFOS = guile.texi
+
+guile_TEXINFOS = preface.texi intro.texi scheme-intro.texi \
+ scheme-ideas.texi scheme-data.texi scheme-procedures.texi \
+ scheme-utility.texi scheme-binding.texi scheme-control.texi \
+ scheme-io.texi scheme-evaluation.texi scheme-memory.texi \
+ scheme-modules.texi scheme-scheduling.texi scheme-options.texi \
+ scheme-translation.texi scheme-debug.texi deprecated.texi \
+ scheme-reading.texi scheme-indices.texi slib.texi posix.texi \
+ expect.texi scsh.texi tcltk.texi scripts.texi gh.texi scm.texi \
+ appendices.texi indices.texi script-getopt.texi data-rep.texi \
+ extend.texi repl-modules.texi srfi-modules.texi misc-modules.texi \
+ ../AUTHORS
+
+# Optionally support building an HTML version of the reference manual.
+
+if HTMLDOC
+
+htmldir = $(prefix)/html/guile-$(VERSION)
+
+html_DATA = guile_toc.html $(shell ls guile_*.html 2>/dev/null)
+
+guile_toc.html: guile.texi $(guile_TEXINFOS)
+ $(TEXI2HTML) -split_chapter guile.texi
+
+endif