summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index ede0d15c1..fcccb2048 100644
--- a/configure.in
+++ b/configure.in
@@ -1417,17 +1417,19 @@ case "$GCC" in
## less than exasperating.
## -Wpointer-arith was here too, but something changed in gcc/glibc
## and it became equally exasperating (gcc 2.95 and/or glibc 2.1.2).
- CFLAGS="$CFLAGS -Wall -Wmissing-prototypes"
+ GCC_CFLAGS="-Wall -Wmissing-prototypes"
# Do this here so we don't screw up any of the tests above that might
# not be "warning free"
if test "${GUILE_ERROR_ON_WARNING}" = yes
then
- CFLAGS="${CFLAGS} -Werror"
+ GCC_CFLAGS="${GCC_CFLAGS} -Werror"
enable_compile_warnings=no
fi
;;
esac
+AC_SUBST(GCC_CFLAGS)
+
## If we're creating a shared library (using libtool!), then we'll
## need to generate a list of .lo files corresponding to the .o files
## given in LIBOBJS. We'll call it LIBLOBJS.