summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 57c06d5ae..ea3ca614b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,7 +67,8 @@ AC_PROG_LN_S
dnl Gnulib.
gl_INIT
dnl FIXME: remove me and the acinclude.m4 code when clock-gettime is
-dnl LGPL-compatible and can be imported normally.
+dnl fixed for clock_getcpuclockid and can be imported normally from
+dnl gnulib.
gl_CLOCK_TIME
AC_PROG_CC_C89
@@ -716,7 +717,6 @@ case $host in
[Define if you have the <winsock2.h> header file.])])
AC_CHECK_LIB(ws2_32, main)
AC_LIBOBJ([win32-uname])
- AC_LIBOBJ([win32-dirent])
if test "$enable_networking" = yes ; then
AC_LIBOBJ([win32-socket])
fi
@@ -1145,19 +1145,19 @@ AC_CHECK_FUNCS(asinh acosh atanh copysign finite sincos trunc)
# use <math.h> so doesn't detect on macro-only systems like HP-UX.
#
AC_MSG_CHECKING([for isinf])
-AC_LINK_IFELSE(AC_LANG_SOURCE(
+AC_LINK_IFELSE([AC_LANG_SOURCE(
[[#include <math.h>
volatile double x = 0.0;
-int main () { return (isinf(x) != 0); }]]),
+int main () { return (isinf(x) != 0); }]])],
[AC_MSG_RESULT([yes])
AC_DEFINE([HAVE_ISINF], 1,
[Define to 1 if you have the `isinf' macro or function.])],
[AC_MSG_RESULT([no])])
AC_MSG_CHECKING([for isnan])
-AC_LINK_IFELSE(AC_LANG_SOURCE(
-[[#include <math.h>
+AC_LINK_IFELSE([AC_LANG_SOURCE([[
+#include <math.h>
volatile double x = 0.0;
-int main () { return (isnan(x) != 0); }]]),
+int main () { return (isnan(x) != 0); }]])],
[AC_MSG_RESULT([yes])
AC_DEFINE([HAVE_ISNAN], 1,
[Define to 1 if you have the `isnan' macro or function.])],
@@ -1438,8 +1438,8 @@ case "$with_threads" in
AC_CACHE_CHECK([whether PTHREAD_ONCE_INIT needs braces],
guile_cv_need_braces_on_pthread_once_init,
- [AC_COMPILE_IFELSE([#include <pthread.h>
- pthread_once_t foo = PTHREAD_ONCE_INIT;],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <pthread.h>
+ pthread_once_t foo = PTHREAD_ONCE_INIT;]])],
[guile_cv_need_braces_on_pthread_once_init=no],
[guile_cv_need_braces_on_pthread_once_init=yes])])
if test "$guile_cv_need_braces_on_pthread_once_init" = yes; then
@@ -1450,8 +1450,8 @@ case "$with_threads" in
# 6.5.30m with GCC 3.3.
AC_CACHE_CHECK([whether PTHREAD_MUTEX_INITIALIZER needs braces],
guile_cv_need_braces_on_pthread_mutex_initializer,
- [AC_COMPILE_IFELSE([#include <pthread.h>
- pthread_mutex_t foo = PTHREAD_MUTEX_INITIALIZER;],
+ [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <pthread.h>
+ pthread_mutex_t foo = PTHREAD_MUTEX_INITIALIZER;]])],
[guile_cv_need_braces_on_pthread_mutex_initializer=no],
[guile_cv_need_braces_on_pthread_mutex_initializer=yes])])
if test "$guile_cv_need_braces_on_pthread_mutex_initializer" = yes; then