summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2008-04-26 21:55:29 +0200
committerLudovic Courtès <ludo@gnu.org>2008-04-26 21:56:02 +0200
commit56ae2148173f0b9a8fe8bb82530113f99f1f364d (patch)
treeed75d3ac409f33ceb61283d599e1d69bfcc9496b /configure.in
parentbd22f1c768e2d5c7ec6264b8c68cc56019daccf4 (diff)
downloadguile-56ae2148173f0b9a8fe8bb82530113f99f1f364d.tar.gz
Only run `test-with-guile-module' when pthread support is built.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 193d6a6c2..fcfe2bf79 100644
--- a/configure.in
+++ b/configure.in
@@ -1166,6 +1166,9 @@ AC_SUBST(SCM_I_GSC_NEED_BRACES_ON_PTHREAD_MUTEX_INITIALIZER, 0)
case "$with_threads" in
"yes" | "pthread" | "pthreads" | "pthread-threads" | "")
+
+ build_pthread_support="yes"
+
ACX_PTHREAD(CC="$PTHREAD_CC"
LIBS="$PTHREAD_LIBS $LIBS"
SCM_I_GSC_USE_PTHREAD_THREADS=1
@@ -1245,6 +1248,10 @@ esac
AC_MSG_CHECKING(what kind of threads to support)
AC_MSG_RESULT($with_threads)
+AM_CONDITIONAL([BUILD_PTHREAD_SUPPORT],
+ [test "x$build_pthread_support" = "xyes"])
+
+
## Check whether pthread_attr_getstack works for the main thread
if test "$with_threads" = pthreads; then