summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2012-03-08 23:50:41 +0100
committerAndy Wingo <wingo@pobox.com>2012-03-08 23:50:41 +0100
commit9adbf27f4e0656f489c8c9fa941da023ee4201ec (patch)
tree83deb16239b7018ba2d699a4307fcbc7fab06d09 /configure.ac
parentf740445a9b5bf0a5e5090f0a2ddaffb2b803bab7 (diff)
downloadguile-9adbf27f4e0656f489c8c9fa941da023ee4201ec.tar.gz
more libgc 7.1 compat
* configure.ac: * libguile/gc.c (GC_set_finalize_on_demand): Check for this function, and shim if it isn't present.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c9a443b56..c506b392e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1232,7 +1232,7 @@ save_LIBS="$LIBS"
LIBS="$BDW_GC_LIBS $LIBS"
CFLAGS="$BDW_GC_CFLAGS $CFLAGS"
-AC_CHECK_FUNCS([GC_do_blocking GC_call_with_gc_active GC_pthread_exit GC_pthread_cancel GC_allow_register_threads GC_pthread_sigmask GC_set_start_callback GC_get_heap_usage_safe GC_get_free_space_divisor GC_gcollect_and_unmap GC_get_unmapped_bytes GC_set_finalizer_notifier])
+AC_CHECK_FUNCS([GC_do_blocking GC_call_with_gc_active GC_pthread_exit GC_pthread_cancel GC_allow_register_threads GC_pthread_sigmask GC_set_start_callback GC_get_heap_usage_safe GC_get_free_space_divisor GC_gcollect_and_unmap GC_get_unmapped_bytes GC_set_finalizer_notifier GC_set_finalize_on_demand])
# Though the `GC_do_blocking ()' symbol is present in GC 7.1, it is not
# declared, and has a different type (returning void instead of