summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2011-04-21 12:27:49 +0200
committerAndy Wingo <wingo@pobox.com>2011-04-21 16:02:09 +0200
commit514ff6ea075f436795ee121b4abeac8a5affe866 (patch)
tree8865c9f9982fada21e9b85faaa7928eebef505fb /configure.ac
parentc3d8450c757d1a98b44b3556a334bbebe1ad6f37 (diff)
downloadguile-514ff6ea075f436795ee121b4abeac8a5affe866.tar.gz
add test that libunistring was built with iconv support
* configure.ac: Add check that libunistring was built with iconv support. Thanks to Mark Weaver for the debugging and test program.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3bb6bf6c3..1e85b5740 100644
--- a/configure.ac
+++ b/configure.ac
@@ -874,6 +874,27 @@ if test "x$LTLIBUNISTRING" = "x"; then
AC_MSG_ERROR([GNU libunistring is required, please install it.])
fi
+AC_MSG_CHECKING([that libunistring was built with iconv support])
+save_LIBS=$LIBS
+LIBS="$LIBS $LIBUNISTRING"
+AC_RUN_IFELSE([AC_LANG_SOURCE([[
+#include <uniconv.h>
+#include <unistring/iconveh.h>
+int
+main (int argc, char *argv[])
+{
+ size_t result_size;
+ return (NULL == u32_conv_from_encoding ("ASCII", iconveh_question_mark,
+ "a", 1,
+ NULL, NULL, &result_size));
+}
+]])],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_RESULT([no])
+ AC_MSG_ERROR([No iconv support. Please recompile libunistring with iconv enabled.])]
+ [AC_MSG_RESULT([yes, hopefully (cross-compiling)])])
+LIBS=$save_LIBS
+
dnl Libffi is needed to compile Guile's foreign function interface, but its
dnl interface isn't exposed in Guile's API.
PKG_CHECK_MODULES(LIBFFI, libffi)