summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2012-01-30 19:59:08 +0100
committerAndy Wingo <wingo@pobox.com>2012-01-30 20:27:35 +0100
commitdfadcf85cb3ae9133dece6bc39ed03dd25323d6e (patch)
tree93c918a793ee86c8406fd1bac521ea2b870361cf /configure.ac
parent252acfe8e70ac4c7d325588ffea1905fcf6f86b2 (diff)
parente1fbe716e8596b7027af57623ebc72a0c6393187 (diff)
downloadguile-dfadcf85cb3ae9133dece6bc39ed03dd25323d6e.tar.gz
Merge remote-tracking branch 'origin/stable-2.0'
Conflicts: libguile/debug.h module/ice-9/psyntax-pp.scm module/ice-9/psyntax.scm module/language/tree-il/peval.scm module/language/tree-il/primitives.scm
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5f9ead1e0..697761fc8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1527,9 +1527,14 @@ case "$GCC" in
## and it became equally exasperating (gcc 2.95 and/or glibc 2.1.2).
## -Wundef was removed because Gnulib prevented it (see
## <http://thread.gmane.org/gmane.lisp.guile.bugs/5329>.)
+
+ ## Build with `-fno-strict-aliasing' to prevent miscompilation on
+ ## some platforms. See
+ ## <http://lists.gnu.org/archive/html/guile-devel/2012-01/msg00487.html>.
+
POTENTIAL_GCC_CFLAGS="-Wall -Wmissing-prototypes \
-Wdeclaration-after-statement \
- -Wswitch-enum"
+ -Wswitch-enum -fno-strict-aliasing"
# Do this here so we don't screw up any of the tests above that might
# not be "warning free"
if test "${GUILE_ERROR_ON_WARNING}" = yes