summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-03-28 22:24:00 -0400
committerMark H Weaver <mhw@netris.org>2013-03-28 22:24:00 -0400
commitc33ecf96a41979be0af1d56a7e12ad7c1196f12b (patch)
tree35e2f32f49f210dced293e77612a7130445281c9 /configure.ac
parent26d148066f9cb20e395a7dc4fefdf2e2ef0b2fb0 (diff)
parent4702deb424633ad02c495c01d950b973c0ead8ea (diff)
downloadguile-c33ecf96a41979be0af1d56a7e12ad7c1196f12b.tar.gz
Merge remote-tracking branch 'origin/stable-2.0'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 85e31704e..e25635b80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -872,6 +872,14 @@ if test "x$HAVE_LIBGMP" != "xyes"; then
AC_MSG_ERROR([GNU MP 4.1 or greater not found, see README])
fi
+dnl `mpz_inits' and `mpz_clears' appeared in GMP 5.0.0.
+save_CPPFLAGS="$CPPFLAGS"
+if test "x$LIBGMP_PREFIX" != "x"; then
+ CPPFLAGS="-I$LIBGMP_PREFIX $CPPFLAGS"
+fi
+AC_CHECK_DECLS([mpz_inits], [], [], [[#include <gmp.h>]])
+CPPFLAGS="$save_CPPFLAGS"
+
dnl GNU libunistring is checked for by Gnulib's `libunistring' module.
if test "x$LTLIBUNISTRING" = "x"; then
AC_MSG_ERROR([GNU libunistring is required, please install it.])