summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2013-03-30 22:56:27 -0400
committerMark H Weaver <mhw@netris.org>2013-03-30 22:56:27 -0400
commit86cf4773ff94a128247d484e6d69786869f41ebc (patch)
treea44cc484c7e1a9d55d957dc54cc8260b496f544d /configure.ac
parentc33ecf96a41979be0af1d56a7e12ad7c1196f12b (diff)
parentb05257b9232e2ee631c28b15cace5981c4927446 (diff)
downloadguile-86cf4773ff94a128247d484e6d69786869f41ebc.tar.gz
Merge remote-tracking branch 'origin/stable-2.0'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 2 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index e25635b80..60aa49f31 100644
--- a/configure.ac
+++ b/configure.ac
@@ -761,7 +761,8 @@ AC_CHECK_FUNCS([DINFINITY DQNAN cexp chsize clog clog10 ctermid \
strcoll strcoll_l newlocale utimensat sched_getaffinity \
sched_setaffinity sendfile])
-AM_CONDITIONAL([HAVE_FORK], [test "x$ac_cv_func_fork" = "xyes"])
+AM_CONDITIONAL([BUILD_ICE_9_POPEN],
+ [test "x$enable_posix" = "xyes" && test "x$ac_cv_func_fork" = "xyes"])
# Reasons for testing:
# netdb.h - not in mingw
@@ -1302,24 +1303,6 @@ if test $scm_cv_struct_linger = yes; then
getsockopt and setsockopt system calls.])
fi
-
-# On mingw, struct timespec is in <pthread.h>.
-#
-AC_MSG_CHECKING(for struct timespec)
-AC_CACHE_VAL(scm_cv_struct_timespec,
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-#include <time.h>
-#if HAVE_PTHREAD_H
-#include <pthread.h>
-#endif]], [[struct timespec t; t.tv_nsec = 100]])],
- [scm_cv_struct_timespec="yes"],
- [scm_cv_struct_timespec="no"]))
-AC_MSG_RESULT($scm_cv_struct_timespec)
-if test $scm_cv_struct_timespec = yes; then
- AC_DEFINE([HAVE_STRUCT_TIMESPEC], 1,
- [Define this if your system defines struct timespec via either <time.h> or <pthread.h>.])
-fi
-
#--------------------------------------------------------------------
#
# Flags for thread support